<div dir="ltr">Hi all , <div style>I have encountered a problem when I tried to pack a script using pp utility and I hope that someone might help me.</div><div style>my OS is windows 7 and I use strawberry.</div><div style>
the modules that I want to pack in my script are:</div><div style><div>use strict;</div><div>use Wx;</div><div>use Net::Telnet;</div><div>use Net::FTP;</div><div>use Time::Local;</div><div style>I use the command pp -o new.exe <a href="http://pusher_25.pl">pusher_25.pl</a> - the exe should be the output.</div>
<div style>the packing seems to be working but when I try to run the exe output file I get an error message :</div><div style><br></div><div style><div>Can&#39;t load &#39;C:\Users\emeiri\AppData\Local\Temp\par-656d65697269\cache-813c3ab5d8</div>
<div>6ea3a9576ea1204f266554e6db7318\4a864d38.dll&#39; for module Wx: load_file:%1 is not</div><div>a valid Win32 application at C:/strawberry/perl/lib/DynaLoader.pm line 190.</div><div> at C:/strawberry/perl/vendor/lib/PAR/Heavy.pm line 120.</div>
<div>Compilation failed in require at script/<a href="http://pusher_25.pl">pusher_25.pl</a> line 3.</div><div>BEGIN failed--compilation aborted at script/<a href="http://pusher_25.pl">pusher_25.pl</a> line 3.</div><div><br>
</div><div style>I used par and pp before in my last laptop that was win7 OS as well, with the same script but now for some reason it is not working.</div><div style><br></div><div style>any help would be <span style="color:rgb(0,0,0);font-family:Arial,&#39;Lucida Grande&#39;,Raanana,sans-serif;font-size:15px">appreciated.</span></div>
</div></div></div>