[Israel.pm] Perl MySQL DBI with SSL - can't connect

Felix Liberman felix.liberman at gmail.com
Tue Jan 24 06:27:05 PST 2012


Hi All,

I'm trying to re-configure my Perl application that communicates with MySQL
server via DBI layer.
Previous version worked perfectly without SSL, but now (for production
mode) higher security measures required, so I switched to SSL.
I run MySQL server with SSL support and even managed to connect via
command-line interface (using standard mysql utility):

{{{
mysql> status
--------------
/{somepath}/bin/mysql  Ver 14.14 Distrib 5.5.20, for Linux (x86_64) using
 EditLine wrapper

Connection id:          34
Current database:       sc_prj_cm
Current user:           {someuser}@{somehost}
SSL:                    Cipher in use is DHE-RSA-AES256-SHA
Current pager:          less
Using outfile:          ''
Using delimiter:        ;
Server version:         5.5.20-log Source distribution
Protocol version:       10
Connection:             {somehost} via TCP/IP
}}}

The DBD::mysql (rev 4.018) module was compiled with SSL enabled option, but
client application fails:

{{{
DBI
connect('database=sc_prj_cm;host={somehost};port=3306;mysql_ssl=1;mysql_ssl_ca_file=/{somepath}/ssl_certs/cacert.pem','{someuser}',...)
failed: SSL connection error at {my source code}
}}}

Both connections (mysql command-line and Perl app)  used the same
certificates on the same host.

Googling around the keywords did not bring much info.

Maybe the local community can help me?


Thanks in advance,
-- 
~Felix_ <http://felixl.coolpage.biz>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.perl.org.il/pipermail/perl/attachments/20120124/cc21b3be/attachment.htm 


More information about the Perl mailing list