[Israel.pm] EPIC debugger not stopping at breakpoint

Gabor Szabo szabgab at gmail.com
Thu Mar 18 23:36:42 PDT 2010


On Fri, Mar 19, 2010 at 1:39 AM, Adam BE <adamb_e at yahoo.com> wrote:
>
> Ok I noticed that I had to start the Debugger first (wasn't intuitive to me) before I could set a breakpoint.
> I thought I might have missed this point in EPIC - yet it still doesn't stop at bp unless I single-step line after line.

So you figured that out. that's good. Yes in this first version I only
allowed setting bookmark while the debugger is running.
Later I understood it isn't such a bright idea but so far I did not
have the time to work on the debugger.


> Back to Padre -
> 1. Remove breakpoint doesn't work  - the line remains marked and next time I run the debugger it still stop at this bp (so it's not just a visual problem).

Could you please open a ticket with this?

> 2. When I quite the Debugger the GUI hangs for ~5 seconds.

and with this?

http://padre.perlide.org/trac/

Regarding the language,  we can have a whole argument weather we
should allow people to program before they fully learn English or if
that should be a prerequisite but if you prefer English you can switch
the language in View/Language/....   or the respective menu item in
Hebrew.


> Is there a working  free Visual Perl Debugger out there?
I am surprised the EPIC debugger does not work for you as it worked
for me when I tried it last time
but you can install Devel::ptkdb. It is quite good.

OTOH you could also contribute to the Padre code base and help us get
it working to your satisfaction.

regards
   Gabor


More information about the Perl mailing list