[Israel.pm] Perl 5.10 has been released

Gabor Szabo gabor at perl.org.il
Tue Jan 8 06:42:18 PST 2008


Actually as the Perl porters stand now it seems that use 5.12 will already 
imply use strict.

Oh and while officially 5.005 is not deprecated now that the 
module installation toolchain only supports 5.6 it is effectively
*really hard* to use 5.005 with CPAN.

Of course those who stick with 5.005 probably don't want the greatest
and bravest of CPAN anyway.

Gabor


On Tue, 18 Dec 2007, Gaal Yahas wrote:

> That would be spelled "use v6" or something starting with "module "...
>
> On Dec 18, 2007 9:49 PM, Shmuel Fomberg <semuelf at 012.net.il> wrote:
>> Hi All.
>>
>> Will they deprecate Perl 5.005 now, or will they wait another century? :-/
>>
>> p.s. I like the idea that writing 'use 5.10' will automatically make switch,
>> state and such available. Pity they didn't made it load strict and warnings
>> too. It could have been 'one statement to rule them all'. :-)
>>
>> Shmuel.
>>
>>



More information about the Perl mailing list