[Israel.pm] Some Issues - Net::Telnet

Yuval Kogman nothingmuch at woobling.org
Sun Jan 29 09:20:46 PST 2006


On Sun, Jan 29, 2006 at 19:07:44 +0200, Semuel Fomberg wrote:
> Hello There.
> 
> I wasn't around for some time, for my domain is down, so I could not
> read/write mail. Now I'm reading though my ISP's mail account. Oh well.
> (if you know about someone that can host my site, that is pretty tiny
> with about 10 hits a day, for 20~30$ per year, please mail me. Thanks.)

There are some nonprofit hosts around, like http://www.epfarms.org

There is no restriction on the content (it's not just for
communities), and the cost is $2 a month.

> 1. The sites complain that I should telnet using VT100 emulation. Can I
> set Net::Telnet to satisfy this?

Term::VT102

> 2. I get a CR character in the beginning of every line. Even though I
> leave the binmode=0 default. (That suppose to deal with the \n
> translation) what am I doing wrong?

binmode => 0 on unix is a no-op. There should be an option in
Net::Telnet to really scrub the lines.

Worst case scenario, locally set $/ to $Socket::CRLF

-- 
 ()  Yuval Kogman <nothingmuch at woobling.org> 0xEBD27418  perl hacker &
 /\  kung foo master: *shu*rik*en*sh*u*rik*en*s*hur*i*ke*n*: neeyah!!!!

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://perl.org.il/pipermail/perl/attachments/20060129/211305b9/attachment.pgp 


More information about the Perl mailing list