[Israel.pm] upgrading to Perl 5.8.4

Offer Kaye oferk at oren.co.il
Thu May 20 00:31:21 PDT 2004


>
> Hello,
>
> I'm using Mandrake 9.1.
> This comes with Perl 5.8.0.
>
> I'd like to upgrade to Perl 5.8.4.
> I'd rather do it through the RPM or the URPMI mechanism, in
> order to have a consistent database. I've managed to find
> perl-5.8.4-2mdk.src.rpm on the net, but I failed to properly
> install it (it wants dependencies which I cannot seem to
> provide).
>
> Can someone, please give me "dumb user" examples how to
> install this from the srouce rpms? say, using the rpm
> mechanism?
>
> Thanks.
>
> --
> Shlomo Yona

By downloading a single rpm and trying to install it manually you are
breaking the RPM method. The correct method would be to add the whole
repository to urpmi and then tell it to install perl-5.8.4. It will then
take care of dependencies.
Here for example is a list of ftp sites that have the perl-5.8.4 rpm:
http://rpm.pbone.net/index.php3/stat/4/idpl/1185729/com/perl-5.8.4-2mdk.i586
.rpm.html

So for example choosing the nluug site you would do from the command line:
urpmi.addmedia nluug_cooker
ftp://ftp.nluug.nl/pub/os/Linux/distr/Mandrake/devel/cooker/i586/Mandrake/RP
MS/ with ../base/hdlist.cz

I'm not quite sure that this works exactly the same way for source RPMs, but
it should be similiar.
Regards,
----------------------------------
Offer Kaye



More information about the Perl mailing list