[Israel.pm] Perl Graphics - GD.pm

Offer Kaye oferk at oren.co.il
Wed Apr 7 22:36:08 PDT 2004


>
> Line 3 of Makefile.PL contains : require 5.6.0;
>
> Does that mean it needs version 5.6 of Perl? Or a module called 5.6.0?
> Where can I get this missing  module? [if indeed it's a module].
>
>
> I'm running Perl 5.005_03 on Solaris 2.6.
> I looked at the GD Readme at
> http://cpan.uwinnipeg.ca/htdocs/GD/README.html - and it says
> that I need
> Perl 5.004 or higher.
>
> Happy holidays/Hag Sameach,
> Srikanth Madani
>

Line 3 of http://search.cpan.org/src/LDS/GD-2.12/Makefile.PL :
"
require 5.6.0;
"

This line "Demands a version of Perl specified by VERSION", see:
http://www.perldoc.com/perl5.8.0/pod/func/require.html

So you might want to:
1. Point out the README vs. Makefile.PL inconsistancy as a bug to the GD
author. Perhaps the required version in the Makefile.PL could be downgraded
to the same version as that required by the GD module itself
2. Upgrade your Perl
3. Install an older version of GD that doesn't require perl 5.6.0

Regards,
----------------------------------
Offer Kaye



More information about the Perl mailing list